Subversion Repositories Kolibri OS

Rev

Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
9045 110d 23h dunkaist /kernel/trunk/ kernel: Check for base+len overflow in is_region_userspace  
9038 111d 13h Boppan /kernel/trunk/ [KERNEL][TASKMAN] Add prefixes to named constants  
9036 111d 13h Boppan /kernel/trunk/ [KERNEL][TASKMAN] Use named constants instead of magic numbers  
9032 111d 15h Boppan /kernel/trunk/core/ [KERNEL][TASKMAN] Document fs_execute function return value  
9031 111d 15h Boppan /kernel/trunk/core/ [KERNEL][TASKMAN] Comment fs_execute function  
8874 132d 00h rgimad /kernel/trunk/ [KERNEL] #4 Preparing to merge legacy TASKDATA into APPDATA:
- use thread state constants instead of hardcoded values
- other small style fixes
 
8869 132d 23h rgimad /kernel/trunk/ [KERNEL] #3 Preparing to merge legacy TASKDATA into APPDATA:
- get rid of CURRENT_TASK
- to APPDATA added new fields which will be used instead of TASKDATA's
- other small fixes
 
8867 133d 19h rgimad /kernel/trunk/ [KERNEL] #2 Preparing to merge legacy TASKDATA into APPDATA:
- rename event_mask in APPDATA to occured_events, cause TASKDATA already has event_mask and they have different meaning and usage
- small fixes
 
8866 133d 23h rgimad /kernel/trunk/ [KERNEL] Preparing to merge legacy TASKDATA into APPDATA:
- now doesnt use TASK_COUNT, now uses [thread_count] global instead of it
- update come copyrights
 
8858 134d 16h rgimad /kernel/trunk/ [KERNEL] Refactoring:
- optimize struct zeroing in sys32.inc
- set_app_param: delete setting completely unused APPDATA.event_filter (also make this field reserved)
- update some copyringhs
- other small fixes
 
8851 135d 21h rgimad /kernel/trunk/ refactoring pid_to_slot:
- use constants instead of hardcoded values
- add more comments
 
8840 136d 12h rgimad /kernel/trunk/core/ Delete unused function check_region (it was commented out years ago) and stub calls of this function.  
8709 179d 16h Coldy / Dll autoload
Kernel
- removed unnecessary and rewrote/add some comments, no code changes
User (lib/dll.obj)
- Introduced new KX header as extension for existing formats
- Added staring KX header processing
- Improved import table test logic, no reason to kill app for import absence - skip
import processing (tnx ProMiNick)
- Add ReadMe.txt
 
8671 194d 00h Coldy /kernel/trunk/ For DLL autoload  
8593 255d 19h rgimad /kernel/trunk/core/ taskman.inc: fixed two vulnerabilities which caused kernel memory corruption on attempt to run apps with illegal addresses in MENUET0x header  
8592 256d 09h rgimad /kernel/trunk/core/ taskman.inc: add comments for unobvious things, no code changes  
8093 381d 06h dunkaist /kernel/trunk/ Assert sizeof.APPDATA=256, use it instead of hardcoded 256 value.  
7276 1264d 08h dunkaist / Enable xsave/xrstor, attempt 2.  
7165 1346d 16h clevermouse /kernel/trunk/ fix FPU after r7124 for other CPU configurations  
7136 1408d 08h dunkaist /kernel/trunk/ Replace 'equ' macros with '=' ones.

They appear in symbols file.
They don't require parentheses.
They are shorter.
 

Show All